Is this lag or an FPS issue?

Discussion on technical issues (installation, launching).
Furiously
Level 0
Posts: 5
Joined: Tue 12 Feb, 2019 10:14 pm

Is this lag or an FPS issue?

Postby Furiously » Tue 12 Feb, 2019 10:30 pm

Hey,

So i've been playing on and off over the last few years. I put up with my lag/FPS issue for a while before getting fed up and quitting for a year, and the cycle continues. I'm hoping you guys can help.

I'm running windows 10, 8gb RAM, 8 core processor, nvidia geforce gtx 760. PC was built in 2014 long after the game came out so i'm certain it's not because my PC can't actually run the game. I'm not tech savvy so someone will know better than I do how good that hardware is.

My internet is wireless, and does have its moments. Generally though when streaming it is fine, other games in the past have been fine (the PC was built to play Evolve and never had any problems), recently played dark souls 3 and it could drop connection here and there but nothing major. I'd love to use ethernet but it isn't an option.

The problem - since starting to play again last week, i've tried to play mainly 1v1. In a good game, i'll get a couple of small spikes for a few seconds each. In a bad game, it is unplayable. Freezes of up to 20 seconds and my army is deleted. I'll 90% of the time get a bit of lag in the first 20-30 seconds of a game.
I've played a 2v2 and a couple of 3v3s tonight, still some freezes but not quite as bad.

So its very inconsistent. I'll go into a game not knowing whether i'll have to give up 5 minutes in or whether i can white-knuckle through it and maybe finish the game.

I reinstalled a couple of days ago - still get massive freezes.
I've tried running in windows 7 compatibility mode as i read windows 10 doesn't like dow2 - didn't seem to do anything.
Tried limiting my FPS with rivatuner - didn't seem to do anything.

I don't know what to do, and I don't know whether it is internet related or whether it is the OS.

I keep coming back hoping the problem will have resolved itself but alas it never does. Would love to play some games with you all.

Please help! Thanks.
User avatar
Broodwich
Level 3
Posts: 398
Joined: Fri 12 Apr, 2013 10:04 pm

Re: Is this lag or an FPS issue?

Postby Broodwich » Tue 12 Feb, 2019 10:47 pm

Sounds like network lag/packet loss to me. Is there any way to try it out for a few days with just ethernet and see how it goes?

DOW2 seems more finicky than a lot of other games. I'm all ethernet, and i can't even remember the last time I had lag or connection issues from any other game. While it is rare, I do get the same problems with DOW2 as you described

It may not even be your wireless connection, your ISP could be fucking up as well, but wireless always exacerbates the problem
Fas est ab hoste doceri
Furiously
Level 0
Posts: 5
Joined: Tue 12 Feb, 2019 10:14 pm

Re: Is this lag or an FPS issue?

Postby Furiously » Wed 13 Feb, 2019 7:10 pm

I can't try ethernet unfortunately, the router is on a different level and i have no ethernet cable.
User avatar
Sex - Murder - Art
Level 2
Posts: 79
Joined: Sun 21 Oct, 2018 10:25 am

Re: Is this lag or an FPS issue?

Postby Sex - Murder - Art » Wed 13 Feb, 2019 9:23 pm

There is also a fact that Relic just doesn't support this game anymore soooooo, we may need t infiltrate into Relic HQ and clean the dust on our dear servers some time. Shouldn't be too hard to get in there since no one in Relic gives a shit anymore.

My internet is also decent, but it acts so different when it come sto playing this game online sometimes.
There are many ways to say the right thing, and I choose the worst way to say it.
Furiously
Level 0
Posts: 5
Joined: Tue 12 Feb, 2019 10:14 pm

Re: Is this lag or an FPS issue?

Postby Furiously » Sun 17 Feb, 2019 2:13 pm

Turning off my firewall seemed to work perfectly for a few days (without compatibility mode) but now the freezing is back. So I’ve just been playing around with settings again. I lowered the resolution a little and ran a performance test. Max FPS 120ish, minimum 4 (it wasn't this low on a bigger resolution). Came out of the menus, and saw this.

https://ibb.co/9s00Hnk

I'm assuming it says "out of vidmem" (video memory) but i've no idea what that means.

Edit: that happened when moving from 1920x1080 to 1768x992 and in windows 7 compatibility mode. Tried again with 1680x1050 and it fixed itself.

The best minimum FPS I can get seems to be 20ish on highest resolution and low settings across the board in windows 7 compatibility mode.

The other computer in the house (on the bottom floor. router is on middle floor. my PC on top floor) seems to get up to 60mb/s download speed whereas mine is lucky to get 1mb, based on how quickly steam has downloaded games in the past. Is it really just down to the network?

Any advice, please?

And what does compatibility mode actually do? I've played a few games with it on and it seems to do nothing.
User avatar
Atlas
Moderator
Posts: 2247
Joined: Sun 02 Feb, 2014 5:23 pm
Location: Tarpon Springs, FL

Re: Is this lag or an FPS issue?

Postby Atlas » Mon 18 Feb, 2019 4:27 am

Hmm, the low on vidm shouldn't be a result of lag whatsoever. Maybe it's an issue with trying to play a non-native resolution?

I can only describe my own stuff. I don't play on any compatibility mode and at highest settings while streaming. I can't remember the last time the game has given me issues when I'm not doing patch work.

We just released the 2.9 beta, maybe try installing that and seeing if the issue goes away? Otherwise, I'll try to think on this as I can't think of anything obvious here.
Atlas: Minister of Common Sense, Reasoning and Similar Sh*t
User avatar
Broodwich
Level 3
Posts: 398
Joined: Fri 12 Apr, 2013 10:04 pm

Re: Is this lag or an FPS issue?

Postby Broodwich » Mon 18 Feb, 2019 6:18 pm

Broodwich wrote:Sounds like network lag/packet loss to me.

Furiously wrote:The other computer in the house (on the bottom floor. router is on middle floor. my PC on top floor) seems to get up to 60mb/s download speed whereas mine is lucky to get 1mb, based on how quickly steam has downloaded games in the past. Is it really just down to the network?

Have you tried playing on the other PC?
Fas est ab hoste doceri
Furiously
Level 0
Posts: 5
Joined: Tue 12 Feb, 2019 10:14 pm

Re: Is this lag or an FPS issue?

Postby Furiously » Mon 18 Feb, 2019 6:26 pm

It isn't mine unfortunately.
User avatar
Broodwich
Level 3
Posts: 398
Joined: Fri 12 Apr, 2013 10:04 pm

Re: Is this lag or an FPS issue?

Postby Broodwich » Mon 18 Feb, 2019 7:21 pm

Maybe ask to borrow it for a few hours?

I'm afraid that without any testing we can't really eliminate any problems. The next best suggestion i can think of is a wireless repeater, but that costs money and may not even fix the problem
Fas est ab hoste doceri
User avatar
Atlas
Moderator
Posts: 2247
Joined: Sun 02 Feb, 2014 5:23 pm
Location: Tarpon Springs, FL

Re: Is this lag or an FPS issue?

Postby Atlas » Mon 18 Feb, 2019 7:27 pm

Well if you are just testing connectivity the fastest way is to just make a temporary wired connection and see if that improves anything.
Atlas: Minister of Common Sense, Reasoning and Similar Sh*t
Paranoid Kamikaze
Level 3
Posts: 369
Joined: Tue 02 Feb, 2016 5:12 am

Re: Is this lag or an FPS issue?

Postby Paranoid Kamikaze » Mon 18 Feb, 2019 8:47 pm

Test FPS by Going to Steam Settings - In-Game Section - Set In-Game FPS Counter to one of your corners and put on High Contrast Colour. Now just go ingame and watch your FPS during your slowdowns. If it's constantly slow then it's a graphics card not being powerful enough problem so you have to turn down settings. If it's just slow in parts where there are lots of things going on then your CPU isn't fast enough.

To test internet speed go to: https://www.speedtest.net/ . If it's a wireless issue then you want to take away anything that could be obstructing the signal or move closer if you can. If wireless is just bad where your comp is you can buy a wifi extender.

If you have memory issues you just have to lower settings. You can monitor with programs like this: https://www.techpowerup.com/gpuz/
Furiously
Level 0
Posts: 5
Joined: Tue 12 Feb, 2019 10:14 pm

Re: Is this lag or an FPS issue?

Postby Furiously » Mon 18 Feb, 2019 9:54 pm

Just played a 1v1 with that FPS counter, it barely ever dipped below 60 FPS. Usually around 70. During a ~5 sec lag spike near the start, the FPS didn't change at all. During a massive 10 second lag spike that got my army deleted, it didn't dip and even went up.

So it is looking like a network issue.

The speedtest earlier on was showing ~15mb download, now its showing 7 or 8mb. My connection sometimes seems to depend on the precise positioning of the wireless adapter in the back of the computer. We're talking hair width precision here as to whether the signal disappears or not. Right clicking on the wifi signal and slecting @status' shows 65 mbps but we all know that isn't actually happening.

So is the solution here a wired connection? Unfortunately it isn't an option. The PC is just too far away from the router.
User avatar
Broodwich
Level 3
Posts: 398
Joined: Fri 12 Apr, 2013 10:04 pm

Re: Is this lag or an FPS issue?

Postby Broodwich » Mon 18 Feb, 2019 10:53 pm

Broodwich wrote:
The next best suggestion i can think of is a wireless repeater
Fas est ab hoste doceri

Return to “Technical issues”



Who is online

Users browsing this forum: No registered users and 0 guests